0029 – Finden

0029 – Finden

Funktion FINDEN()

Im heutigen Tutorial wird die Funktion FINDEN() erläutert.
Mit der Funktion kann die Position bestimmt werden an welcher ein bestimmtes Wort in einer Zelle steht.
Es wird die Position ausgegeben, an der das gesuchte Wort zum ersten Mal auftaucht.
Der Unterschied zur Funktion SUCHEN ist, dass bei der Funktion FINDEN Gross- und Kleinschreibung unterschieden wird.

Die Funktion FINDEN() besitzt 3 Argumente:

1.Suchtext:             der Text, der gesucht werden soll.
2.Text:                    die Spalte, in der gesucht werden soll.
3.Erstes_Zeichen:    die Position, ab der gesucht werden soll.

Die Eingabe des Ersten_Zeichen ist optional. Wird hier kein Wert angegeben, beginnt Excel die Suche ab der ersten Stelle.

Als Beispiel wird das Teilwort UMS in der Spalte A gesucht. Die Funktion kann sowohl direkt eingegeben werden oder über das Menü Funktion… ausgewählt werden.

a. Eingabe der Funktion

Hierzu wird in der Zelle H2 folgende Eingabe getätigt: =FINDEN(„UMS“;A2;1). Mit dieser Eingabe wird die Position bestimmt, an der das erste Mal die Wortfolge „UMS“ auftaucht.

Die Eingabe ist sowohl in der Zelle H2 als auch in der Eingabeleiste sichtbar:

Dies wird analog für die Zellen H3 bis H9 wiederholt:



Achtung
: Bahnumsatz z.B. wurde nicht gefunden, da nach „UMS“ und nicht „ums“ gesucht wurde.

b. Über die Menüleiste

Die Funktion kann auch über die Menüleiste gewählt werden: Im Menü unter Einfügen -> Funktion… auswählen.
Bei der Maske Funktion einfügen kann unter der Funktion suchen nach der Funktion FINDEN gesucht werden:

Bei der Maske Funktionsargumente wird unter FINDEN folgende Auswahl getätigt:

–> Suchetext: „UMS“
–> Text: A2
–> Position: 1

Zum Beenden des Assistenten wird auf OK geklickt.

Tipp: mit der WENN-Funktion (vgl. Tutorial 0025) und der Funktion ISTFEHLER (vgl. Tutorial 0024) kann der Fehlerwert #WERT! bspw. durch eine 0 ersetzt werden.
Dazu wird die folgende Eingabe getätigt: =WENN(ISTFEHLER(FINDEN(„ums“;A2;1));0;FINDEN(„ums“;A2;1))

Für Fragen, Hinweise und Anregungen können Sie uns unter der folgenden E-Mail-Adresse erreichen: tutorials@accon-rvs.de